Obsługa błędów w Excelu

Czasami zdarza się, że w Excelu formuła zwraca błąd lub dane nie są poprawne. Jak sobie poradzić w takiej sytuacji? Przede wszystkim trzeba poznać rodzaje błędów, na jakie można trafić.

INFO_27_8.jpg

Błędy zwracane przez formuły

Zaczniemy od tabeli zawierającej błędy, które mogą zwracać formuły (Tabela 1).

Komunikaty błędów zwracane przez formuły są mało przyjazne dla człowieka, dlatego jeśli wiadomo, z jakiego powodu się pojawiły, można zastąpić je przyjaznym komunikatem. Na przykład funkcja WYSZUKAJ.PIONOWO zwraca błąd #N/D!, kiedy nie uda jej się znaleźć produktu na liście (Rysunek 1):

=WYSZUKAJ.PIONOWO(B2;$F$4:$G$10;2;0)

My chcemy ten komunikat błędu zamienić na bardziej zrozumiałą / tekstową informację. Możemy w tym celu użyć funkcji JEŻELI.BŁĄD, ewentualnie JEŻELI.ND (Excel 2013), które w sytuacji napotkania błędu zwracają inną wartość. Funkcja JEŻELI.ND reaguje tylko na błąd #N/D!. W takiej sytuacji poprawiona formuła może wyglądać następująco:

=JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(B2;$F$4:$G$10;2;0);”Brak produktu”)

Wykorzystałeś swój limit bezpłatnych treści

Pozostałe 82% artykułu dostępne jest dla zalogowanych użytkowników portalu. Zaloguj się, wybierz plan abonamentowy albo kup dostęp do artykułu/dokumentu.

Wybierz abonament już od 100 zł miesięcznie Pokaż abonament
Dwutygodniowy dostęp bez zobowiązań Wybieram

Abonament już od 100 zł miesięcznie

Dwutygodniowy dostęp bez zobowiązań

Pełen dostęp do wszystkich treści portalu
to koszt 100 zł miesięcznie
przy jednorazowej płatności za rok

WYBIERAM

Dwutygodniowy dostęp do wszystkich treści
portalu za 99 zł netto, które odliczymy od ceny
regularnej przy przedłużeniu abonamentu

WYBIERAM

Pełen dostęp do wszystkich treści portalu
to koszt 100 zł miesięcznie
przy jednorazowej płatności za rok

Dwutygodniowy dostęp do wszystkich treści
portalu za 99 zł netto, które odliczymy od ceny
regularnej przy przedłużeniu abonamentu

WYBIERAM